smate.sk

lemon blog

Google plugin pre Eclipse & ukážka: Java a GWT na Google App Engine

| 0 comments

Ako som nedávno písal Google app engine podporuje Javu. Dnes si ukážeme ako nainštalovať Google Plugin pre Eclipse, ktorý veľmi uľahčuje vývoj aplikácie pre prostredie App Engine. Samozrejme, budeme potrebovať Eclipse (integrované vývojárske prostredie – IDE).  Eclipse je veľmi sa často využíva pre vývoj rôznych aplikácií v Jave, C++ alebo napríklad v PHP. Ja osobne preferujem Netbeans (od firmy Sun), tento ale Google ignoruje.

Pre nainštalovanie pluginu od Googlu klikneme: menu Help -> Software Updates -> tab Avaliable Software.  Následne cez tlačidlo Add Site…  pridáme adresu http://dl.google.com/eclipse/plugin/3.4. Do zoznamu dostupných aplikácií pribudnú položky Plugin a SDKs. Zaškrtneme obe. Ostáva už len samotná inštalácia cez tlačidlo Instal… Eclipse je potrebné reštartovať.

google app engine eclipse plugin

Keď všetko prebehlo bez problémov, môžeme vytvoriť nový projekt. V menu vyberieme File -> New -> Web Application Project.  Vyplníme meno projektu a package a klikneme Finish. Vytvorí sa ukážková aplikácia, ktorú možno otestovať na localhoste (v project explorer nad projektom Debug as -> Web Application). Spustí sa server a následne aplikácia.

google app engine eclipse plugin

Ak chceme aplikáciu otestovať priamo na Google App Engine, musíme mať samozrejme vytvorený účet a projekt na appengine.google.com.  Do konfiguračného súboru appengine-web.xml je potrebné doplniť Application Identifier. Ak je identifier napr.: testidentifier výsledné XMLko bude vyzerať nejako takto:

<?xml version="1.0" encoding="utf-8"?>
<appengine-web-app xmlns="http://appengine.google.com/ns/1.0">
<application>testidentifier</application>
<version>1</version>
...
</appengine-web-app>

A teraz už stačí len kliknúť na ikonku app engine v toolbare , vyplniť svoj email a heslo. Plugin sa postará o deploy aplikácie.

Moju ukážkovú aplikáciu si môžete pozrieť tu.  Prajem veľa úspechov pri programovaní.

PS: Tento plugin som pôvodne chcel nainštalovať pod Linuxom, osbahuje však chybu . Predpokladám, že bude čoskoro opravená a plugin bude možné používať plnohodnotne aj pod linuxom.

PS2: (edit 29.04. 2009) Plugin pod linuxom už funguje bez problémov.

Leave a Reply

Required fields are marked *.